パソコン

AndroidStudioで古いプロジェクトを開けなくなったときの対処法

AndroidStudioをアップデートしたら、古いプロジェクトを開くことができなくなりました。

・flutter cleanする

・flutter doctorする → 問題なし

・AndroidStudioを開き直す

・ChatGPTにエラー文そのまま載せて、聞いてみるが訳がわからない。gradleのファイルが怪しいことは分かった。

・gradleのファイルのバージョンをAndroidStudioの提案通りに上げる。→直らない

★新しくFlutterプロジェクトを作って、gradle→build.gradleのファイルの中を見比べる。

buildscript {
    ext.kotlin_version = '1.7.10'
    repositories {
        google()
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:7.3.0'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
    }
}

ここの、バージョンの部分「1.7.10」と「7.3.0」を新しいプロジェクトと同じにしたら直りました。

最初、このバージョンの部分を、AndroidStudioに提案されたバージョンに一回変更していたので、まさかここが間違っていると思わず、ここまでで3日くらいかかりました…。疲れました。